Which php libraries are installed by default on my server?

The PHP libraries installed on your server depend on its type and operating system.

Dedicated

CentOS 6 x64 Plesk

  • php-snmp-5.3.3-23.el6_4.x86_64
  • php-mysql-5.3.3-23.el6_4.x86_64
  • php-ldap-5.3.3-23.el6_4.x86_64
  • php-mbstring-5.3.3-23.el6_4.x86_64
  • php5-ioncube-loader-4.0.14-12042719.x86_64
  • php-pear-1.9.4-4.el6.noarch
  • php-xml-5.3.3-23.el6_4.x86_64
  • php-gd-5.3.3-23.el6_4.x86_64
  • php-soap-5.3.3-23.el6_4.x86_64
  • php-dba-5.3.3-23.el6_4.x86_64
  • php-bcmath-5.3.3-23.el6_4.x86_64
  • psa11-php-fakepackage-11.0.9-cos6.build110120608.16.x86_64
  • psa-php5-configurator-1.6.2-cos6.build110120608.16.x86_64
  • php-common-5.3.3-23.el6_4.x86_64
  • php-cli-5.3.3-23.el6_4.x86_64
  • php-odbc-5.3.3-23.el6_4.x86_64
  • php-imap-5.3.3-23.el6_4.x86_64
  • php-5.3.3-23.el6_4.x86_64
  • php-xmlrpc-5.3.3-23.el6_4.x86_64
  • php-pdo-5.3.3-23.el6_4.x86_64

CentOS 6 x64 - No control panel

  • php-snmp-5.3.3-23.el6_4.x86_64
  • php-mysql-5.3.3-23.el6_4.x86_64
  • php-ldap-5.3.3-23.el6_4.x86_64
  • php-mbstring-5.3.3-23.el6_4.x86_64
  • php-pear-1.9.4-4.el6.noarch
  • php-xml-5.3.3-23.el6_4.x86_64
  • php-gd-5.3.3-23.el6_4.x86_64
  • php-soap-5.3.3-23.el6_4.x86_64
  • php-dba-5.3.3-23.el6_4.x86_64
  • php-bcmath-5.3.3-23.el6_4.x86_64
  • php-common-5.3.3-23.el6_4.x86_64
  • php-cli-5.3.3-23.el6_4.x86_64
  • php-odbc-5.3.3-23.el6_4.x86_64
  • php-imap-5.3.3-23.el6_4.x86_64
  • php-5.3.3-23.el6_4.x86_64
  • php-xmlrpc-5.3.3-23.el6_4.x86_64
  • php-pdo-5.3.3-23.el6_4.x86_64

Fedora 19 x64

  • php-cli-5.5.3-1.fc19.x86_64
  • php-pecl-jsonc-1.3.1-1.fc19.x86_64
  • php-imap-5.5.3-1.fc19.x86_64
  • php-snmp-5.5.3-1.fc19.x86_64
  • php-process-5.5.3-1.fc19.x86_64
  • php-xml-5.5.3-1.fc19.x86_64
  • php-common-5.5.3-1.fc19.x86_64
  • php-5.5.3-1.fc19.x86_64
  • php-ldap-5.5.3-1.fc19.x86_64
  • php-pdo-5.5.3-1.fc19.x86_64
  • php-gd-5.5.3-1.fc19.x86_64
  • php-odbc-5.5.3-1.fc19.x86_64
  • php-pear-1.9.4-20.fc19.noarch
  • php-dba-5.5.3-1.fc19.x86_64
  • php-mbstring-5.5.3-1.fc19.x86_64

CentOS 5 - No control panel

  • php-pdo-5.1.6-40.el5_9
  • php-pear-1.4.9-8.el5
  • php-soap-5.1.6-40.el5_9
  • php-common-5.1.6-40.el5_9
  • php-mbstring-5.1.6-40.el5_9
  • php-ncurses-5.1.6-40.el5_9
  • php-xmlrpc-5.1.6-40.el5_9
  • php-dba-5.1.6-40.el5_9
  • php-cli-5.1.6-40.el5_9
  • php-ldap-5.1.6-40.el5_9
  • php-snmp-5.1.6-40.el5_9
  • php-bcmath-5.1.6-40.el5_9
  • php-5.1.6-40.el5_9
  • php-xml-5.1.6-40.el5_9
  • php-gd-5.1.6-40.el5_9
  • php-mysql-5.1.6-40.el5_9
  • php-imap-5.1.6-40.el5_9
  • php-devel-5.1.6-40.el5_9

CentOS 5 x64 - Plesk

  • php53-gd-5.3.3-13.el5_8
  • php53-sqlite2-5.3.2-11011812
  • php5-ioncube-loader-4.0.14-12042718
  • php53-xml-5.3.3-13.el5_8
  • psa11-php-fakepackage-11.0.9-cos5.build110120608.16
  • php53-mbstring-5.3.3-13.el5_8
  • php53-pdo-5.3.3-13.el5_8
  • php53-imap-5.3.3-13.el5_8
  • php53-5.3.3-13.el5_8
  • psa-php53-configurator-1.6.2-cos5.build110120608.16
  • php53-cli-5.3.3-13.el5_8
  • php53-common-5.3.3-13.el5_8
  • php53-mysql-5.3.3-13.el5_8

CentOS 5 x64 - No control panel

  • php-5.1.6-40.el5_9
  • php-ncurses-5.1.6-40.el5_9
  • php-pear-1.4.9-8.el5
  • php-common-5.1.6-40.el5_9
  • php-ldap-5.1.6-40.el5_9
  • php-xmlrpc-5.1.6-40.el5_9
  • php-cli-5.1.6-40.el5_9
  • php-snmp-5.1.6-40.el5_9
  • php-mysql-5.1.6-40.el5_9
  • php-bcmath-5.1.6-40.el5_9
  • php-soap-5.1.6-40.el5_9
  • php-pdo-5.1.6-40.el5_9
  • php-dba-5.1.6-40.el5_9
  • php-mbstring-5.1.6-40.el5_9
  • php-devel-5.1.6-40.el5_9
  • php-gd-5.1.6-40.el5_9
  • php-imap-5.1.6-40.el5_9
  • php-xml-5.1.6-40.el5_9

CentOS 5 x64 - cPanel

  • cpanel-php53-Structures-Graph-1.0.4-3.cp1136
  • cpanel-php53-PEAR-Command-Packaging-0.3.0-2.cp1136
  • cpanel-php53-Net-UserAgent-Detect-2.5.2-3.cp1136
  • cpanel-php53-Net-Socket-1.0.10-3.cp1136
  • cpanel-php53-Net-SMTP-1.6.1-3.cp1136
  • cpanel-php53-XML-Parser-1.3.4-3.cp1136
  • cpanel-php53-5.3.17-6.cp1136
  • cpanel-php53-HTTP-1.4.1-3.cp1136
  • cpanel-php53-SOAP-0.13.0-2.cp1136
  • cpanel-php53-Net-URL-1.0.15-3.cp1136
  • cpanel-php53-Console-Getopt-1.3.1-2.cp1136
  • cpanel-php53-Date-1.4.7-3.cp1136
  • cpanel-php53-sourceguardian-8.2-2.cp1136
  • cpanel-php53-Archive-Tar-1.3.10-3.cp1136
  • cpanel-php53-ioncube-4.5.0-1.cp1136
  • cpanel-php53-zendopt-5.5.0-2.cp1136
  • cpanel-php53-XML-Util-1.2.1-3.cp1136
  • cpanel-php53-Auth-SASL-1.0.6-3.cp1136
  • cpanel-php53-Mail-Mime-1.8.3-2.cp1136
  • cpanel-php53-File-1.4.1-2.cp1136
  • cpanel-php53-DB-1.7.14-3.cp1136
  • cpanel-php53-HTML-Template-IT-1.3.0-2.cp1136
  • cpanel-php53-PEAR-1.9.4-4.cp1136
  • cpanel-php53-HTTP-Request-1.4.4-3.cp1136
  • cpanel-php53-Log-1.12.7-2.cp1136
  • cpanel-php53-Mail-1.2.0-2.cp1136
  • cpanel-php53-XML-RPC-1.5.5-3.cp1136

Ubuntu 10.4 - Plesk

  • libapache2-mod-php5
  • php-http-request
  • php-mail
  • php-mail-mime
  • php-mail-mimedecode
  • php-net-dime
  • php-net-smtp
  • php-net-socket
  • php-net-url
  • php-pear
  • php-soap
  • php5
  • php5-cgi
  • php5-cli
  • php5-common
  • php5-curl
  • php5-gd
  • php5-imap
  • php5-ioncube-loader
  • php5-ldap
  • php5-mcrypt
  • php5-mysql
  • php5-odbc
  • php5-pspell
  • php5-snmp
  • php5-sqlite
  • php5-xmlrpc
  • php5-xsl
  • psa-php5-configurator
  • psa11-php-fakepackage

VPS

CentOS 6 - Plesk

  • php-imap-5.3.3-23.el6_4.x86_64
  • php-mbstring-5.3.3-23.el6_4.x86_64
  • php-pecl-memcache-3.0.5-4.el6.x86_64
  • php5-ioncube-loader-4.0.14-12042719.x86_64
  • php-cli-5.3.3-23.el6_4.x86_64
  • php-pdo-5.3.3-23.el6_4.x86_64
  • php-mysql-5.3.3-23.el6_4.x86_64
  • php-pgsql-5.3.3-23.el6_4.x86_64
  • php-xml-5.3.3-23.el6_4.x86_64
  • php-xmlrpc-5.3.3-23.el6_4.x86_64
  • php-ldap-5.3.3-23.el6_4.x86_64
  • php-pecl-apc-3.1.9-2.el6.x86_64
  • php-common-5.3.3-23.el6_4.x86_64
  • psa-php5-configurator-1.6.2-cos6.build110120608.16.x86_64
  • php-5.3.3-23.el6_4.x86_64
  • php-odbc-5.3.3-23.el6_4.x86_64
  • php-soap-5.3.3-23.el6_4.x86_64
  • php-pear-1.9.4-4.el6.noarch
  • php-gd-5.3.3-23.el6_4.x86_64
  • psa11-php-fakepackage-11.0.9-cos6.build110120608.16.x86_64

Fedora 14

  • php-xml-5.3.6-1.fc14.i686
  • php-imap-5.3.6-1.fc14.i686
  • php-mbstring-5.3.6-1.fc14.i686
  • php-xmlrpc-5.3.6-1.fc14.i686
  • php-ldap-5.3.6-1.fc14.i686
  • php-snmp-5.3.6-1.fc14.i686
  • php-common-5.3.6-1.fc14.i686
  • php-cli-5.3.6-1.fc14.i686
  • php-pear-1.9.2-3.fc14.noarch
  • php-pecl-ncurses-1.0.1-1.fc13.i686
  • php-mysql-5.3.6-1.fc14.i686
  • php-pgsql-5.3.6-1.fc14.i686
  • php-odbc-5.3.6-1.fc14.i686
  • php-soap-5.3.6-1.fc14.i686
  • php-dba-5.3.6-1.fc14.i686
  • php-bcmath-5.3.6-1.fc14.i686
  • php-devel-5.3.6-1.fc14.i686
  • php-pdo-5.3.6-1.fc14.i686
  • php-5.3.6-1.fc14.i686
  • php-gd-5.3.6-1.fc14.i686
  • php-mcrypt-5.3.6-1.fc14.i686

CentOS 6 - No control panel

  • php-5.3.3-23.el6_4.x86_64
  • php-odbc-5.3.3-23.el6_4.x86_64
  • php-imap-5.3.3-23.el6_4.x86_64
  • php-soap-5.3.3-23.el6_4.x86_64
  • php-mbstring-5.3.3-23.el6_4.x86_64
  • php-pear-1.9.4-4.el6.noarch
  • php-gd-5.3.3-23.el6_4.x86_64
  • php-pecl-memcache-3.0.5-4.el6.x86_64
  • php-cli-5.3.3-23.el6_4.x86_64
  • php-pdo-5.3.3-23.el6_4.x86_64
  • php-mysql-5.3.3-23.el6_4.x86_64
  • php-pgsql-5.3.3-23.el6_4.x86_64
  • php-xml-5.3.3-23.el6_4.x86_64
  • php-xmlrpc-5.3.3-23.el6_4.x86_64
  • php-ldap-5.3.3-23.el6_4.x86_64
  • php-pecl-apc-3.1.9-2.el6.x86_64
  • php-common-5.3.3-23.el6_4.x86_64

CentOS 5 - No control panel

  • php-common-5.1.6-40.el5_9
  • php-5.1.6-40.el5_9
  • php-pdo-5.1.6-40.el5_9
  • php-devel-5.1.6-40.el5_9
  • php-ldap-5.1.6-40.el5_9
  • php-xml-5.1.6-40.el5_9
  • php-snmp-5.1.6-40.el5_9
  • php-mbstring-5.1.6-40.el5_9
  • php-odbc-5.1.6-40.el5_9
  • php-cli-5.1.6-40.el5_9
  • php-xmlrpc-5.1.6-40.el5_9
  • php-pear-1.4.9-8.el5
  • php-gd-5.1.6-40.el5_9
  • php-imap-5.1.6-40.el5_9
  • php-ncurses-5.1.6-40.el5_9

Was This Article Helpful?
Thank You For Your Feedback
Glad we helped! Anything more we can do for you?
Sorry about that. How can we be more helpful?