Skip to main content
  • GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    efoertsch
    New

    Trying to run Mongo on VPS server getting 'cannot execute binary file'

    I have purchased the 'Gen4 VPS Linux - 1 CPU/1 GB RAM ' server to play around with node.js and MongoDB.  I am having problems getting MongoDB to run. 

     

    I tried installing Mongo using this    reference: https://docs.mongodb.com/manual/tutorial/install-mongodb-on-red-hat/

    but found that the VPS account would not let me create the /etc/yum.repos.d/mongodb-org-4.4.repo file.

     

    So went to plan B and used this reference : http://junonguyen.herokuapp.com/2016/01/24/How-to-install-MongoDB-on-Web-Linux-Hosting-GoDaddy/ 

    to manually download and install MongoDB.

     

    But when I try to execute the command to start Mongo :

     

    mongod --dbpath $HOME/data/db

     

    I get the error:  'cannot execute binary file'

     

    But the file attributes look good (from what I can tell - I am not a real server guy, afatester is my userid)

    -rwxr-xr-x 1 afatester afatester     7683 Feb  7 12:31 install_compass

    -rwxr-xr-x 1 afatester afatester 43147504 Feb  7 12:31 mongo

    -rwxr-xr-x 1 afatester afatester 68692572 Feb  7 12:31 mongod

    -rwxr-xr-x 1 afatester afatester 52399600 Feb  7 12:31 mongos

     

    Any ideas? Am I missing something simple?

     

    I tried GoDaddy Chat and Phone support and the last recommendation was to go with an +$100/mo plan that comes with support - which is more than I want to spend on this playing around. 

     

     

    0 REPLIES 0