cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Cannot access WP Admin Panel Lost Password

I recently upgraded my website to attempt WooCommerce functionality.  Since the time I have installed the WooCommerce and its few features like product blocks, credit card processing, and cart button; I have had to rebuild the pages three times.  I would appreciate some assistance.

 

1) I ran a backup and restore to 5.1 Wordpress

2) I ran WooCommerce without anything but BAC and Check Processing

3) I ran WooCommerce without product blocks and cart button

4) I ran WooCommerce without My Account Pages enabled

5) I ran WooCommerce without updating Accelerated Mobile Pages plugins and Theme updates

 

After all of this dissecting, I have reason to believe the problem lies in the My Account feature of WooCommerce.  The My Account Page overrides certain code in the WP Admin.  The minute I run any feature that creates the My Account page functionality for WooCommerce; I lose my ability to reset my WP-Admin Password i.e., the Lost Password hyperlink at: https://yoursite.com/wp-login.php

 

1 ACCEPTED SOLUTION

Hello All:

 

It always seems to be a simple fix.  For those of you who have this problem, here is the temporary fix I utilized...

 

1) Disable Account Creation sections in the Setting / Emails tab

     a. Allow customers to create an account during checkout

     b. Allow customers to created an account on the "My account" page

     c. When creating an account automatically create username from the customer's email address

     d. When creating an account, automatically generate an account password

2) Disable My Account Page in Settings / Advanced tab

3) Refresh you WP-Admin Login page and hover over the Lost Password link.  The link should read correctly now.

 

 

View solution in original post

2 REPLIES 2

Hello All:

 

It always seems to be a simple fix.  For those of you who have this problem, here is the temporary fix I utilized...

 

1) Disable Account Creation sections in the Setting / Emails tab

     a. Allow customers to create an account during checkout

     b. Allow customers to created an account on the "My account" page

     c. When creating an account automatically create username from the customer's email address

     d. When creating an account, automatically generate an account password

2) Disable My Account Page in Settings / Advanced tab

3) Refresh you WP-Admin Login page and hover over the Lost Password link.  The link should read correctly now.

 

 

View solution in original post

Community Manager

Thanks @susanf1 for coming back and sharing the fix!! Other GoDaddy customers who may be experiencing the same issue will really appreciate this. Take care!

Rachel

RachelM - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.