cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

500 internal server error when editing wordpress page

Hi there,

 

I try endlessly to get it working but it keep getting the error message 500

I recently just migrate from localhost to the godaddy, it all work good, except when you try to load something or edit something, it showed internal server error on google consoles.

 

Do anyone have the same problem and please give me some advise. (edit .htacess with no sucess)

 

https://img42.com/2xRCe

my comparison between localhost php and godaddy php

localhost: www.kareseniors.com.au/local.html

godaddy: www.kareseniors.com.au/test.php

 

any help i greatly appreciated

 

thank you

 

 

6 REPLIES 6
Community Manager
Community Manager

Re: 500 internal server error when editing wordpress page

Hi, @midi. Welcome to GoDaddy Community!

 

To clarify, are you certain the error in your screenshot is causing the 500 ISE? The pictured error seems to be related to needing a Google Maps API key. If you haven't set up an API key, you may need to do so. I'd suggest searching Google's documentation to find out how to do that. If you already have a key, you may want to check it's configuration. I know that you can limit it to only be accessed in certain ways. Hope that helps. 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.
New
Solution

Re: 500 internal server error when editing wordpress page

 

Hi Jesse,

 

Thanks for the response, and it is not the google API, because even if the API problem, it jsut wont show the map.

 

But i think i find hte solution, it is my plugins, i need to disabled all plugin and re-enabled all back, and now its all work good

 

thanks

New

HTTP Error 500 - Internal Server Error The FastCGI process exceeded configured request timeout

Hey Guys,

 

I am getting this error

HTTP Error 500 - Internal Server Error  The FastCGI process exceeded configured request timeout

whenever i try to upload a file. I did a research on this bug and came to know that this is because of the PHP execution time limit. I tried creating a .user.ini file in the directory where i have installed word press and added the code like this.

 

fastcgi.impersonate = 1
fastcgi.logging = 0
cgi.fix_pathinfo=1
cgi.force_redirect = 0  

max_execution_time = 90
upload_max_filesize = 100M
memory_limit = 128M
post_max_size = 128M

But that did not helped. I tried many other methods too, but really don't know what is the right solution. I have contacted GoDaddy customer care regarding this but they did not help me. Can anybody please suggest me  the best solution for this fix.. ?

 

 

How to identify and error in my server log

Hi - I'm trying to install a theme on my wordpress site. The theme itself installed OK but i'm having trouble with one of the required plug ins. The theme is called Carrie and the plugin is called Carrie Meta Boxes.

 

The plug in causes an internal server error.

I've asked the support team for the theme, who replied as follows

 

"Hello, looks like some required PHP library does not installed on your server. You need to ask your hosting support (or check server logs yourself if you know how to do this) to check what error exactly and in which file you got."

 

I don't know much about PHP, but i did look at the server logs. Nothing glaringly said error (and a ctrl+F5 showed the word error wasn't in the log anywhere).

 

Basically can anyone unpack this for me a bit - what exactly would I be looking for in the server log? Or if you've experienced something similar what is your advice?

 

Thanks

Wordpress 500 Error Theme Options

I'm having issues getting this to post my original text Smiley Happy

 

I'm using the Seashell Wordpress theme on my site but I'm running into a 500 error issue on the theme options page. After several hours of researching the issue and contacting the developer of the theme, the most likely culprit seemed the PHP memory limit issue.

 

I followed the instructions to increase the memory limit by adding the below, but it didn't seem to help. I also tested recycling my app pool after adding this just in case.

 

Added to wp-config.php:

define( 'WP_MEMORY_LIMIT', '256M' );

 

Additionally, I added the following to the .user.ini file, but alas, it didn't help.

 

Added to .user.ini:

memory_limit = 256M
file_uploads = On
post_max_size = 256M
upload_max_filesize = 256M

 

My questions are:

  1. Are there any other common WP solutions that might resolve this issue?
  2. Is there a way to view more technical data about the 500 error within GoDaddy? The logs I can find don't seem to have any data relevant to the errors I'm seeing.

 

Helpful info

GoDaddy Ultimate Hosting w/ Plesk

Wordpress 4.7.2

Re: Wordpress 500 Error Theme Options

but when i install my plugin it create internal server error .please help me if anyone have solution