cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

The firewall is blocking admin-ajax.php file on a WordPress website

After installing a new SSL certificate that I purchased outside Godaddy I am wasn't able to access the admin-ajax.php file via HTTPS. I created a new subdomain and installed a new WordPress website and tried again but without any luck, so it has nothing to do with the rest of my plugins, this solution seems to be the right fix. It suggests going to my products page and navigating to website security then whitelisting my IP or the admin-ajax.php file. However, I did not purchase a Website security service so how can I fix this issue?

9 REPLIES 9
Super User IV

@omar_elhadi 

 

A couple of questions - 

1) What is your domain & what type of server are you on?

2) What makes you say that there is a "firewall" blocking this - are you getting a specific error that says that??

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

@PL281 

1. my website domain is gis-gate.com and it is hosted on a Web Hosting with cPanel.

2. Everything works fine when I go through HTTP. However, when I switch to HTTPS I get the error 404 cannot load the admin-ajax.php file. I have tried tons of solutions even starting from scratch with a new subdomain. Hereafter, I started to believe that it is a firewall issue especially after reading this article and this answer.

 

@omar_elhadi 

 

The good news / bad news is your site IS actually working fine - I was able to get to the site and a number of pages like https://gis-gate.com/2020/07/27/%d9%85%d8%ac%d8%a7%d9%84%d8%a7%d8%aa-%d8%a7%d9%84%d8%ad%d9%82%d9%88%... without issue.

 

This suggests it is something on your local computer - have you tried a private browsing window / different browser / different network connection

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Thanks for the quick scan and yes there is no issue in the front end.

You see my problem appears when I want to make a new page on WordPress and exactly when I activate the visual page builder, that is when I start getting the error. In my WordPress settings, I configured the site to work through HTTPS and the admin to work through HTTP until my admin account has been hacked! That is why I am bound to stick with HTTPS. 

Now if I want to write a new article I have to remove the redirection to HTTPS codes from .htaccess and deactivate all related plugins. which puts me in great danger during the process.

 

@omar_elhadi 

 

Something seems odd there - so a couple of questions

1) What PHP version are you running

2) Could you by chance post a loom video to show this happening... a couple of comments / things to check

 

a) Settings -> General do you have the HTTPS:// for both URLs

b) You mentioned redirects - personally I've always let WordPress handle this for me - the only thing in my htaccess file is the default permalinks

c) I do use Really Simple SSL plugin to make sure the links / paths are all updated correctly

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

@PL281 

Please refer to this video where I answered all your questions 

@omar_elhadi 

 

This is great - so some more questions

1) Have you tried updating the admin URL in the settings screen and not just in the address bar - the reason I ask is that there are some settings / references in the database that if all you are doing is changing the address bar - those other elements are still loading over HTTP and so you have mixed content

 

2) I couldn't tell what editor you said you are using - have you tried to disable the editor

 

3) can you check in the file manager in wp-admin for an error log to see if there is anything posted

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

@PL281 

1) Yes I tried now again and got the same error

2) I am using the classic editor and I cannot disable it my page composer relies on it

3) There are no related errors to this issue 😞

@omar_elhadi 

 

If you'd like to setup a user for me and message it via direct message - I can take a quick look - I may not be able to find specifically what's going on - it seems like everything is set correctly - It just seems really odd that https would affect the admin like that

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community