cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Obsolete and doesn't work with WordPress

For the past two months or so, I have had issues updating my WordPress (and the PHP) for this website (that I've hosted on Go Daddy for YEARS).  Today I keep getting 400 errors every time I access the Plesk dashboard. I contact Go Daddy. Their solution - to move my account to a Deluxe Plesk hosting account for a dollar more a month. Surprise -- that's the account I have. The guy spent more time trying to sell me five years of the same hosting I already have (where my WordPress install isn't working properly) than he did trying to help me fix the problem - the 400 error + the PHP so I can upgrade my WordPress to the latest version. 

 

So the question is - do I upgrade to an actual WordPress account on GoDaddy and pay a year in advance not knowing if it's going to work and just start with a fresh install? Or do I find another hosting service? Thoughts? Advice?