Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Unexpected error for zone file upload

We keep on getting Unexpected errors in uploading the DNS zone file for our domain. The same file was uploaded fine from Godaddy support, and they said they are using windows7 machine. However, we tried the upload function on multiple Windows10 and Mac servers with different browsers, chrome, IE, firefox, and they are all failed. 


Can anyone help to confirm if the zone file upload function actually work in windows 10 or Mac server? I hope this is not only working in Windows7 machine.


EDIT: The initial issue mentioned in this thread has been resolved. Zone files can now be uploaded from computers outside of our network. 


@krafttechgroup - Thanks for following up. I can confirm that this is still an issue. Essentially uploading zone files will not work unless it's done from a computer within our network. I double checked this and duplicated it with our advanced team. We'll make sure there is follow up with the agents/supervisor you spoke with so everyone is on the same page.


However, one additional thing to note is that even when uploaded from our side, if there is a conflict in one of the records (like being improperly formatted or duplicated), the upload may still fail. Within exported zone files in our system, you will see this notice:


; Please note that we do NOT offer technical support for any use
; of this zone data, the BIND name server, or any other third-
; party DNS software.
; Use at your own risk.

As indicated, support agents won't be able to troubleshoot a zone file in this format. If you provide a zone file to upload and it produces an error, support will not be able to help you identify what is wrong within it. Hope that helps clarify the issue. Again, sorry for any frustration. 


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.

View solution in original post


Hi @Quantifeed, thanks for posting.

I haven't seen any issues like this.

It might be related to the actual zone file itself. Do you also see this error when you try to upload a different zone file or a zone file for another domain?

Gary - GoDaddy | Community Moderator
24/7 Support | Check System Status

Hi Gary,


Thanks for the reply. However, it's still failed even when I tried to upload the exact same file that I got from the "Export Zone File" function. 


Also, I tried to upload a zone file with only 1 line and it still fails:

test1 3600 IN CNAME


The error code returned is 422 with the response body:

{"code":"MissingArgument","message":"Expired or invalid\r\nParameter name: X-XSRF-TOKEN","detail":null,"fields":[]}


Here is the


Request header:
Request URL:
Request Method: POST
Status Code: 422 / Unprocessable Entity


Request payload:

Content-Disposition: form-data; name=""; filename="xxx.comx.txt"
Content-Type: text/plain

test1 3600 IN CNAME


Response body:

{"code":"MissingArgument","message":"Expired or invalid\r\nParameter name: X-XSRF-TOKEN","detail":null,"fields":[]}





We tried with different versions of Firefox (i.e. 54.0.1., 52.0.1, 51.0.1) and they are all failed with just uploading ta testing zone file with 1 entry (example in previous post). The same zone file is uploading without problem by GoDaddy support so it's pretty sure the file content is ok. However, we are failed to do it from our end with different browsers, different machines (i.e. Mac and Windows10) and different network providers.


Appreciate any help on this as this is very annoying if we need to call the GoDaddy support to upload the file.

We get exactly the same issue. Tried multiple Geographic locations (Dublin, UK and Amserdam) Chrome, Edge and FF.


If we send the file to a godaddy tech they are able to upload without issue.


Did you manage to find a resolution? I've been quite frustrated with phone support blaming internet interference.

Unfortunately there is no answer for that. I have contacted the support many times, but they said there isn't much for them to follow up as they can't replicate the problem from their side.


It's good to know that we are not the only one experiencing the same problem. Really hope someone from GoDaddy team can follow up on this.

Same issue here..  the GUI will not allow me to import a simple zone file.. I stripped it down to a simple one line A record import and no-go.   Can GoDaddy confirm this 'Advanced' tool is even working (as someone posted that it is not working in another thread)?   I have 24 zones and multiple records to update and done manually through the GUI is going to take forever...

We are experiencing the same issues described by OP. Tested different computers, browsers, etc. GoDaddy Support had no problems uploading the UNIX version exported from GoDaddy, but we are unable to import the file even when attempting to do so with the file just downloaded from the GoDaddy export. I have reduced the file to a single line (1 record) and get the same error (extremely generic, unhelpful in diagnosing issue):Capture.PNG


I was looking forward to not having to do 12+ domains with multiple records by hand, but I guess that's my only choice. This is very disappointing and if I had known this wasn't going to work, I would have chosen another DNS provider.

I'm having the same issue.

Tried changing the file formats (UTF-8, Unicode, ANSI) and line endings (Windows/Unix). Even tried re-uploading the Export file I downloaded a minute earlier (both Unix and Windows formats). Just same old "An unexpected error occurred. If this issue continues, contact support."
I'm trying to do this to a domain I have been Delegated Access too. Could that be the issue vs a domain in my own account?

Sadly, I abandoned all hope of GoDaddy helping or fixing this issue with the zone file import; and to think I switched my domains over to GoDaddy in part due to their support.   I did solve my issue however using their domain zone templating tools.  My issue was that our co-lo forced us to change our public facing IP's from one series of numbers to another and it would be done all at once; meaning for me, changing 300+ A and SPF records in a matter of minutes.  If done via the GUI, it would take hours and that is too much unacceptable down time.  Using the templating tools, I was able to snapshot the current zones we manage (~24), make my edits for what the future IP's will be to those templates (took a few hours, but at least our sites were up), and then, at the time of the transition, apply the saved templates to my impacted zones which only took minutes and not hours.   Ideally, I would have preferred to dump my zone data to files, edit the files en masse using simple search and replace tools, and re-import the zones at the appropriate time.  It would have been so much easier.  I hope this tip about using the template tools helps others in a similar predicament. 

I'm not sure why my post was marked as the solution or why this is marked as solved. Does the upload work now? What was causing the issue?

At least on my end, the problem is in no way solved. The fact that we are forced to edit zone files directly, and cannot upload the resulting file, and that the GoDaddy GUI was stripped of the ability to bulk edit/delete records means that the service is really not suitable anymore for any but the simplest cases. I have no idea what they are thinking, unless the high-cost DNS package restores the functionality, and these changes are to drive up revenue. In any case, we are outta here.

Did this ever get resolved?


If i export the zone file and then import it... it fails just like all of the other customers. I have about 200 domains i'm moving from Rackspace's DNS and its unacceptable.


How do we troubleshoot when your exported file will not import?

Unfortunately not. The only option we had after multiple calls with their support was to manually enter everything into DNS templates and then cut them over. Completely unacceptable. For us, we only had about 100 entries to create but they wouldn't budge on helping at all or even admitting that it's an issue on their end. Good luck

After several attempts and after not having a satisfy response from the support, we wrote a script using the Godaddy API (from the equivalent of curl in PowerShell).



Same bug for me.
The support team upload the file and it worked. (after 20 minutes of discussions... Not really effective)


Looks like they protect site with CSRF/XSRF, and something go wrong ;( 
Import is not work
Support can not help

Any News From Support?

I'm having the same issue uploading their own exported zone file back in. Support was a huge letdown for this one. They advised they cannot help and the only option is to manually enter all of the entries back in. This is not acceptable for a company that requires consistent uptime for production environments. Even worse, you can't add any new DNS entries until your name servers are pointing to GoDaddy's which means there is no way this can be done without downtime. 


Not sure why this post is marked resolved, when there's no explanation detailing said resolution.


I'm also unable to get a zone file to upload successfully, and would love to see GoDaddy address the issue.  At the very least, at least acknowledge it's broken and remove the feature as an option.


The only reason I even want this feature to work is because checking the "Keep the current nameservers for this domain(s)" box during an account change, also resulted in not following through on stated functionality.

Community Manager

Hi @Quantifeed@obiweb@gCloud@ckcjam@Herbst@Rmmteam@Rocky_Squirrel@PCGIT@myitguy@Sylvain@daharon01. Thanks for sharing about this issue. Sorry it's taken so long to get you a response Man Embarassed I was able to review this with our advanced support team and it turns out that this is an issue that our developers are aware of. I made sure to share the link to this thread in the ticket where this is being worked. I'll try to update this thread if there is a resolution. Until then, you should be able to either manually update records or get in touch with our support team for assistance. Sorry for the trouble everyone! 


JesseW - GoDaddy | Community Manager | 24/7 support available at | Remember to choose a solution and give kudos.